Forbury Add-in Loading Issue

Incident Report for Forbury

Resolved

This incident has been resolved.
Posted May 28, 2026 - 11:10 NZST

Investigating

We are aware that some customers are experiencing issues loading the Forbury Add-in. We are currently investigating and will provide updates here as more information becomes available. If you are affected, please raise a support ticket.
Posted May 27, 2026 - 10:09 NZST
This incident affected: Forbury Models.