Excel crashes during model restore

Incident Report for Forbury

Resolved

Microsoft have deployed a fix to all Excel release channels.
Posted May 28, 2025 - 12:07 NZST

Monitoring

Microsoft has identified the issue and is rolling out a fix to Excel version 2504 and above.

Currently, we are monitoring the status of these update across our team internally and it appears to have resolved the issue for everyone affected.

We encourage you to apply these updates and once again enable auto-updating inside Excel.

If these updates do not fix the issue for you, please let us know as soon as possible by contacting support (https://support.forburyproperty.com/hc/en-us/requests/new).
Posted May 19, 2025 - 15:06 NZST

Identified

We have identified this to be a Microsoft issue introduced into Excel at Version 2504, where it is not allowing successful restore of models and crashing. Currently, our only known solution is to roll-back your Excel version to Version 2503 (Build 18623.20208).

For additional assistance, please don't hesitate to contact to support (https://support.forburyproperty.com/hc/en-us/requests/new).
Posted May 16, 2025 - 12:58 NZST
This incident affected: Forbury Models.