Support link issue
Incident Report for Forbury
Resolved
This incident has been resolved.
Posted Nov 04, 2022 - 16:50 NZDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 04, 2022 - 14:07 NZDT
Investigating
We’re currently experiencing a bug that is impacting the ability for some users to access support via the support tab on the portal. We're aware of the issue and are working hard to resolve it.

If you need to access support, please visit https://support.forburyproperty.com/hc/en-us
Posted Nov 04, 2022 - 12:24 NZDT
This incident affected: Forbury Portal.