Unable to login using SSO

Incident Report for Forbury

Resolved

This incident has now been resolved.
Please reach out to Forbury support at support@forburyproperty.com if you have any further issues.
Posted Apr 22, 2025 - 12:53 NZST

Investigating

We're currently experiencing an interruption to the Forbury Portal, that may be impacting your ability to login.

We're aware of the issue, are working hard to resolve it and apologise for any inconvenience this may have caused you at this time.

Until this is resolved, please log in using your username and password instead of SSO. If you need your username and password reset, please email support@forburyproperty.com and we can help you reset your log in details.
Posted Apr 22, 2025 - 12:08 NZST
This incident affected: Forbury Portal, Forbury Models, and Forbury Account.