Excel Add-in Outage

Incident Report for Forbury

Resolved

The wide-spread Microsoft service outage has been fully resolved. All systems are now operating normally. We’ve monitored the service to ensure stability and confirmed that no further impact is occurring.

If you continue to experience any issues, please contact our support team.
Posted Oct 30, 2025 - 15:28 NZDT

Identified

There is currently a wide-spread Microsoft service outage that is impacting our Excel-based add-in. We are aware of the situation and investigating options to restore the service.
Posted Oct 30, 2025 - 06:17 NZDT
This incident affected: Forbury Models.