Forbury Add-in Not Loading
Incident Report for Forbury
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 10:50 NZDT
Identified
We’re currently experiencing a bug that is impacting the ability for some users to load the Forbury Add-In. We're aware of the issue and are working hard to resolve it.

If you need to access support, please visit https://support.forburyproperty.com/hc/en-us
Posted Nov 24, 2022 - 19:24 NZDT
This incident affected: Forbury Models.